IBM AT&T VPN client on Linux (Ubuntu)

A couple of months ago AT&T release a beta version of their VPN Client for linux.

Unfortunately they released the client as a RPM ( RedHat package ) and not
as an Ubuntu DEB package.

But help was nearby, on this website I found how to convert the RPM
package to an Ubuntu DEB package.

http://blog.afmacedo.com/?p=11

And here you can download the latest IBM AT&T VPN Client
for Linux (@ 07/01/09 )

ftp://ftp.attglobal.net/pub/client/linux/agnclient-1.0-2.0.1.3000.i386.rpm

After converting and installing I could find the app here :

Internet -> AT&T Global Network Client

And check it out AT&T VPN client on Linux

This entry was posted in linux and tagged , , . Bookmark the permalink.

12 Responses to IBM AT&T VPN client on Linux (Ubuntu)

  1. Abel Alaniz says:

    Hello,

    I have Ubuntu at home.. I tried to convert??

    Reading state information… Done
    debhelper is already the newest version.
    debhelper set to manually installed.
    dpatch is already the newest version.
    The following extra packages will be installed:
    libc6-dev linux-libc-dev zlib1g-dev
    Suggested packages:
    glibc-doc manpages-dev
    The following NEW packages will be installed:
    libc6-dev libssl-dev linux-libc-dev zlib1g-dev
    0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
    Need to get 6145kB of archives.
    After this operation, 23.2MB of additional disk space will be used.
    Err http://ftp.us.archive.ubuntu.com hardy-updates/main linux-libc-dev 2.6.24-22.45
    404 Not Found [IP: 91.189.88.40 80]
    Get:1 http://ftp.us.archive.ubuntu.com hardy-updates/main libc6-dev 2.7-10ubuntu4 [3344kB]
    Err http://security.ubuntu.com hardy-security/main linux-libc-dev 2.6.24-22.45
    404 Not Found
    Get:2 http://ftp.us.archive.ubuntu.com hardy/main zlib1g-dev 1:1.2.3.3.dfsg-7ubuntu1 [160kB]
    Err http://ftp.us.archive.ubuntu.com hardy-updates/main libssl-dev 0.9.8g-4ubuntu3.3
    404 Not Found [IP: 91.189.88.40 80]
    Err http://security.ubuntu.com hardy-security/main libssl-dev 0.9.8g-4ubuntu3.3
    404 Not Found
    Fetched 3504kB in 46s (75.5kB/s)
    Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/l/linux/linux-libc-dev_2.6.24-22.45_i386.deb 404 Not Found
    Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/o/openssl/libssl-dev_0.9.8g-4ubuntu3.3_i386.deb 404 Not Found
    E: Unable to fetch some archives, maybe run apt-get update or try with –fix-missing?
    * Building package…
    * Cleaning…

    Not able to convert the package, check the .log files for more info!

    Please Help.

  2. Abel Alaniz says:

    I did find the application at /Desktop/agnclient-1.0~2.0.1.3000/usr/share/applications

    Yet when I double click the ICON I get and error that it could not find the /opt/agns/bin/agnsclient

    but that does exist.

    Details: Failed to execute child process “/opt/agns/bin/agnclient” (No such file or directory)

  3. Thai Dang Vu says:

    Hi,

    Does anybody still have that rpm file?

    Thanks.

  4. Buz says:

    Hi Abel,

    I got the exact same problem today – were you able to solve it ? If so, could you post the solution ?

    Thanks

  5. Eric says:

    anyone know where I can download this rpm?

  6. seb says:

    I recently get VPN program errors when trying to connect. The status messages indicate that the authentication succeeds but shortly after that the VPN connection drops before seeing any data sent through. The detailed log file NetVPN.txt shows this (it tries several IPs in that way):

    [10-06-2010 11:40:15] NetVPN: Logon event.
    [10-06-2010 11:40:15] SSL: SSLOpen() completed successfully
    [10-06-2010 11:40:15] SSL: Connection requested to server: 204.146.24.56
    [10-06-2010 11:40:15] SSL: Connection requested to port: 443
    [10-06-2010 11:40:16] SSL: SSL_get_verify_result() failed.
    [10-06-2010 11:40:16] SSL: SSL connection attempt to 204.146.24.56 failed.
    [10-06-2010 11:40:16] SSL: SSL connection attempt failed with rc =[0].
    [10-06-2010 11:40:16] SSL: Cannot negotiate TCP-SSL connection: socket is invalid.
    [10-06-2010 11:40:16] SSL: Cannot send TCP-SSL logout: socket is invalid.
    [10-06-2010 11:40:16] SSL: SSLClose() started
    [10-06-2010 11:40:16] NetVPN: NetVPN ending.

    I’m using:
    A&T 2.0.0.2030
    Ubuntu 10.04 and Ubuntu 8.04

    Any idea?

  7. Andre Metelo says:

    Seb, I’m having the same problem here… It goes through all vpn addresses with this error.

    Ubuntu 8.04, AT&T 2.0.1.3000

  8. seb says:

    Andre, I got it working now by using AT&T 2.0.1.3003

  9. Andre Metelo says:

    Thanks seb. Where did you find it? Unfortunately, I’m stuck in Asia for awhile without Intranet access…

  10. Andre Metelo says:

    For future reference.. Here goes a tutorial on how to find v 2.0.1.3003 and how to install it (including coversion from rpm to deb!

    http://www.nowhere.dk/articles/installing_at_t_global_network_client_on_ubuntu

  11. zeus says:

    Thanks for this walkthrough – I’m trying to create the deb on ubuntu 15.10 using the script and get the following error during dpkg-buildpackage:

    applying patch 01_ubuntu_porting to ./ …touch: cannot touch ‘etc/rc.d/init.d/agnclientd’: No such file or directory
    touch: cannot touch ‘etc/rc.d/init.d/agnLogd’: No such file or directory
    failed.

    Any idea why it’s trying to create an entry in the centos location for init.d rather than the ubuntu /etc/init.d location?

Leave a Reply

Your email address will not be published. Required fields are marked *

Please leave these two fields as-is:

Protected by Invisible Defender. Showed 403 to 807,320 bad guys.